import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<?FROM database\\.)(.+?\\b)";
final String string = "select a.record_id, a.name, b.person FROM database.atable a join database.btable b on b.id= a.id;\n"
+ "select c.record_id, c.name, d.person FROM database.ctable c join database.dtable d on c.id= d.id;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}