use strict;
my $str = 'select a.record_id, a.name, b.person FROM database.atable a join database.btable b on b.id= a.id;
select c.record_id, c.name, d.person FROM database.ctable c join database.dtable d on c.id= d.id;';
my $regex = qr/(<?FROM database\.)(.+?\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}