using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<?FROM database\.)(.+?\b)";
string input = @"select a.record_id, a.name, b.person FROM database.atable a join database.btable b on b.id= a.id;
select c.record_id, c.name, d.person FROM database.ctable c join database.dtable d on c.id= d.id;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}