re = /(<?FROM database\.)(.+?\b)/m
str = 'select a.record_id, a.name, b.person FROM database.atable a join database.btable b on b.id= a.id;
select c.record_id, c.name, d.person FROM database.ctable c join database.dtable d on c.id= d.id;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end