#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\*(?=\S).*?(?<=[^\s*])\*(?!\S)"
Local $sString = "*foo 1 * 2 bar* foo *b* azz *qu **ux*" & @CRLF & _
"*****foo 1 * 2 bar* foo *b* azz *qu **ux*" & @CRLF & _
"** some text" & @CRLF & _
"" & @CRLF & _
"so * this one* should not be matched" & @CRLF & _
"*this one * and *this o*ne should not be matched" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")