using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*(?=\S).*?(?<=[^\s*])\*(?!\S)";
string input = @"*foo 1 * 2 bar* foo *b* azz *qu **ux*
*****foo 1 * 2 bar* foo *b* azz *qu **ux*
** some text
so * this one* should not be matched
*this one * and *this o*ne should not be matched
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}