import Foundation
let pattern = #"\*(?=\S).*?(?<=[^\s*])\*(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
*foo 1 * 2 bar* foo *b* azz *qu **ux*
*****foo 1 * 2 bar* foo *b* azz *qu **ux*
** some text
so * this one* should not be matched
*this one * and *this o*ne should not be matched
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)