import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*(?=\\S).*?(?<=[^\\s*])\\*(?!\\S)";
final String string = "*foo 1 * 2 bar* foo *b* azz *qu **ux*\n"
+ "*****foo 1 * 2 bar* foo *b* azz *qu **ux*\n"
+ "** some text\n\n"
+ "so * this one* should not be matched\n"
+ "*this one * and *this o*ne should not be matched\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}