# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[^|\n]*\|)?[^|\n](?=[^|\n]*\|)/$1a/gm;t' <<< "++++|+++This|Is|An|Example++|++++
+
+|+
+|+|+
"