use strict;
my $str = '++++|+++This|Is|An|Example++|++++
+
+|+
+|+|+
';
my $regex = qr/(^[^|\n]*\|)?[^|\n](?=[^|\n]*\|)/mp;
my $subst = '$1a';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";