$re = '/(^[^|\n]*\|)?[^|\n](?=[^|\n]*\|)/m';
$str = '++++|+++This|Is|An|Example++|++++
+
+|+
+|+|+
';
$subst = "$1a";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;