using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^|\n]*\|)?[^|\n](?=[^|\n]*\|)";
string substitution = @"$1a";
string input = @"++++|+++This|Is|An|Example++|++++
+
+|+
+|+|+
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}