import re
regex = re.compile(r"(^[^|\n]*\|)?[^|\n](?=[^|\n]*\|)", flags=re.MULTILINE)
test_str = ("++++|+++This|Is|An|Example++|++++\n\n"
"+\n"
"+|+\n"
"+|+|+\n")
subst = "$1a"
result = regex.sub(subst, test_str)
if result:
print(result)