package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?\/)\d{4}-\d{2}-\d{2}$`)
var str = `
my-file-path/wefw/wefw/2022-03-20
my-file-path/wefw/2022-01-02
my-file-path/wef/wfe/wefw/wef/2021-02-03
my-file-path/wef/wfe/wef/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}