import re
regex = re.compile(r"^(.*?\/)\d{4}-\d{2}-\d{2}$", flags=re.MULTILINE)
test_str = ("\n"
"my-file-path/wefw/wefw/2022-03-20\n"
"my-file-path/wefw/2022-01-02\n"
"my-file-path/wef/wfe/wefw/wef/2021-02-03\n"
"my-file-path/wef/wfe/wef/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")