re = /^(.*?\/)\d{4}-\d{2}-\d{2}$/m
str = '
my-file-path/wefw/wefw/2022-03-20
my-file-path/wefw/2022-01-02
my-file-path/wef/wfe/wefw/wef/2021-02-03
my-file-path/wef/wfe/wef/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end