import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?\\/)\\d{4}-\\d{2}-\\d{2}$";
final String string = "\n"
+ "my-file-path/wefw/wefw/2022-03-20\n"
+ "my-file-path/wefw/2022-01-02\n"
+ "my-file-path/wef/wfe/wefw/wef/2021-02-03\n"
+ "my-file-path/wef/wfe/wef/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}