const regex = / ?\b(Fwd:)|\[(.*?)\] ?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' ?\\b(Fwd:)|\\[(.*?)\\] ?', 'gi')
const str = `Fwd: [ProQuest Alert] test fwd:TestFwd: test2fwd: fwd:test3 Fwd:`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);