use strict;
my $str = 'Fwd: [ProQuest Alert] test fwd:TestFwd: test2fwd: fwd:test3 Fwd:';
my $regex = qr/ ?\b(Fwd:)|\[(.*?)\] ?/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";