$re = '/ ?\b(Fwd:)|\[(.*?)\] ?/i';
$str = 'Fwd: [ProQuest Alert] test fwd:TestFwd: test2fwd: fwd:test3 Fwd:';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;