re = / ?\b(Fwd:)|\[(.*?)\] ?/i
str = 'Fwd: [ProQuest Alert] test fwd:TestFwd: test2fwd: fwd:test3 Fwd:'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result