import re
regex = re.compile(r" ?\b(Fwd:)|\[(.*?)\] ?", flags=re.IGNORECASE)
test_str = "Fwd: [ProQuest Alert] test fwd:TestFwd: test2fwd: fwd:test3 Fwd:"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)