using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^#EXTINF:.*?\btvg-name=""([^""]*)"".*\R(https?:\/\/\S*)";
string input = @"#EXTM3U
#EXTINF:-1 tvg-id="" tvg-name=""|NL| NPO 1 HD"" tvg-logo=""http://134.255.234.197/logos/npo1.png"" group-title=""NL| NEDERLAND"",|NL| NPO 1 HD
http://localhost.dummy.proof:80/123456/654321/0123
#EXTINF:-1 tvg-id="" tvg-name=""|NL| NPO 2 HD"" tvg-logo=""http://134.255.234.197/logos/npo2.png"" group-title=""NL| NEDERLAND"",|NL| NPO 2 HD
http://localhost.dummy.proof:80/654321/123456/3210
#EXTINF:-1 tvg-id="" tvg-name=""|NL| NPO 3 HD"" tvg-logo=""http://134.255.234.197/logos/npo3.png"" group-title=""NL| NEDERLAND"",|NL| NPO 3 HD
http://localhost.dummy.proof:80/416352/524163/0231";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}