const regex = /^#EXTINF:.*?\btvg-name="([^"]*)".*\R(https?:\/\/\S*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#EXTINF:.*?\\btvg-name="([^"]*)".*\\R(https?:\\\/\\\/\\S*)', 'gm')
const str = `#EXTM3U
#EXTINF:-1 tvg-id="" tvg-name="|NL| NPO 1 HD" tvg-logo="http://134.255.234.197/logos/npo1.png" group-title="NL| NEDERLAND",|NL| NPO 1 HD
http://localhost.dummy.proof:80/123456/654321/0123
#EXTINF:-1 tvg-id="" tvg-name="|NL| NPO 2 HD" tvg-logo="http://134.255.234.197/logos/npo2.png" group-title="NL| NEDERLAND",|NL| NPO 2 HD
http://localhost.dummy.proof:80/654321/123456/3210
#EXTINF:-1 tvg-id="" tvg-name="|NL| NPO 3 HD" tvg-logo="http://134.255.234.197/logos/npo3.png" group-title="NL| NEDERLAND",|NL| NPO 3 HD
http://localhost.dummy.proof:80/416352/524163/0231`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}