# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^#EXTINF:.*?\btvg-name=\"([^\"]*)\".*\R(https?:\/\/\S*)"
test_str = ("#EXTM3U\n"
"#EXTINF:-1 tvg-id=\"\" tvg-name=\"|NL| NPO 1 HD\" tvg-logo=\"http://134.255.234.197/logos/npo1.png\" group-title=\"NL| NEDERLAND\",|NL| NPO 1 HD\n"
"http://localhost.dummy.proof:80/123456/654321/0123\n"
"#EXTINF:-1 tvg-id=\"\" tvg-name=\"|NL| NPO 2 HD\" tvg-logo=\"http://134.255.234.197/logos/npo2.png\" group-title=\"NL| NEDERLAND\",|NL| NPO 2 HD\n"
"http://localhost.dummy.proof:80/654321/123456/3210\n"
"#EXTINF:-1 tvg-id=\"\" tvg-name=\"|NL| NPO 3 HD\" tvg-logo=\"http://134.255.234.197/logos/npo3.png\" group-title=\"NL| NEDERLAND\",|NL| NPO 3 HD\n"
"http://localhost.dummy.proof:80/416352/524163/0231")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.