import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^#EXTINF:.*?\\btvg-name=\"([^\"]*)\".*\\R(https?:\\/\\/\\S*)";
final String string = "#EXTM3U\n"
+ "#EXTINF:-1 tvg-id=\"\" tvg-name=\"|NL| NPO 1 HD\" tvg-logo=\"http://134.255.234.197/logos/npo1.png\" group-title=\"NL| NEDERLAND\",|NL| NPO 1 HD\n"
+ "http://localhost.dummy.proof:80/123456/654321/0123\n"
+ "#EXTINF:-1 tvg-id=\"\" tvg-name=\"|NL| NPO 2 HD\" tvg-logo=\"http://134.255.234.197/logos/npo2.png\" group-title=\"NL| NEDERLAND\",|NL| NPO 2 HD\n"
+ "http://localhost.dummy.proof:80/654321/123456/3210\n"
+ "#EXTINF:-1 tvg-id=\"\" tvg-name=\"|NL| NPO 3 HD\" tvg-logo=\"http://134.255.234.197/logos/npo3.png\" group-title=\"NL| NEDERLAND\",|NL| NPO 3 HD\n"
+ "http://localhost.dummy.proof:80/416352/524163/0231";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}