// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^#EXTINF:.*?\btvg-name="([^"]*)".*\R(https?:\/\/\S*)"#).unwrap();
let string = "#EXTM3U
#EXTINF:-1 tvg-id=\"\" tvg-name=\"|NL| NPO 1 HD\" tvg-logo=\"http://134.255.234.197/logos/npo1.png\" group-title=\"NL| NEDERLAND\",|NL| NPO 1 HD
http://localhost.dummy.proof:80/123456/654321/0123
#EXTINF:-1 tvg-id=\"\" tvg-name=\"|NL| NPO 2 HD\" tvg-logo=\"http://134.255.234.197/logos/npo2.png\" group-title=\"NL| NEDERLAND\",|NL| NPO 2 HD
http://localhost.dummy.proof:80/654321/123456/3210
#EXTINF:-1 tvg-id=\"\" tvg-name=\"|NL| NPO 3 HD\" tvg-logo=\"http://134.255.234.197/logos/npo3.png\" group-title=\"NL| NEDERLAND\",|NL| NPO 3 HD
http://localhost.dummy.proof:80/416352/524163/0231";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}