#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*FLAGS\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?$"
Local $sString = "FLAGS DCP" & @CRLF & _
"FLAGS PRE" & @CRLF & _
"FLAGS 4CH" & @CRLF & _
"FLAGS SCMS" & @CRLF & _
"FLAGS DCP PRE 4CH SCMS" & @CRLF & _
"FLAGS PRE 4CH DCP SCMS" & @CRLF & _
"FLAGS 4CH DCP PRE SCMS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")