using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*FLAGS\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?$";
string input = @"FLAGS DCP
FLAGS PRE
FLAGS 4CH
FLAGS SCMS
FLAGS DCP PRE 4CH SCMS
FLAGS PRE 4CH DCP SCMS
FLAGS 4CH DCP PRE SCMS";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}