$re = '/^\s*FLAGS\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?$/m';
$str = 'FLAGS DCP
FLAGS PRE
FLAGS 4CH
FLAGS SCMS
FLAGS DCP PRE 4CH SCMS
FLAGS PRE 4CH DCP SCMS
FLAGS 4CH DCP PRE SCMS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);