import Foundation
let pattern = #"^\s*FLAGS\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?\s*(DCP|4CH|PRE|SCMS)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
FLAGS DCP
FLAGS PRE
FLAGS 4CH
FLAGS SCMS
FLAGS DCP PRE 4CH SCMS
FLAGS PRE 4CH DCP SCMS
FLAGS 4CH DCP PRE SCMS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)