import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*FLAGS\\s*(DCP|4CH|PRE|SCMS)?\\s*(DCP|4CH|PRE|SCMS)?\\s*(DCP|4CH|PRE|SCMS)?\\s*(DCP|4CH|PRE|SCMS)?$";
final String string = "FLAGS DCP\n"
+ "FLAGS PRE\n"
+ "FLAGS 4CH\n"
+ "FLAGS SCMS\n"
+ "FLAGS DCP PRE 4CH SCMS\n"
+ "FLAGS PRE 4CH DCP SCMS\n"
+ "FLAGS 4CH DCP PRE SCMS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}