#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:[^/]|(?<!/)/(?!/))*МОСКВА.+?(?=//|$)"
Local $sString = "какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА " & @CRLF & _
"дом 10/2 // еще что-то" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА " & @CRLF & _
"дом 10/2 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")