import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^/]|(?<!/)/(?!/))*МОСКВА.+?(?=//|$)";
final String string = "какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА \n"
+ "дом 10/2 // еще что-то\n\n\n"
+ "какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА \n"
+ "дом 10/2 ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}