using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^/]|(?<!/)/(?!/))*МОСКВА.+?(?=//|$)";
string input = @"какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА
дом 10/2 // еще что-то
какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА
дом 10/2 ";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}