$re = '/(?:[^/]|(?<!/)/(?!/))*МОСКВА.+?(?=//|$)/s';
$str = 'какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА
дом 10/2 // еще что-то
какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА
дом 10/2 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);