#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-1]?\d|2[0-3])(?::([0-5]?\d))?(?::([0-5]?\d))"
Local $sString = "00:00:00" & @CRLF & _
"00:00:01" & @CRLF & _
"23:59:17" & @CRLF & _
"01:01:01" & @CRLF & _
"10:17:25" & @CRLF & _
"09:56:17" & @CRLF & _
"22:56:59" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")