const regex = /([0-1]?\d|2[0-3])(?::([0-5]?\d))?(?::([0-5]?\d))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-1]?\\d|2[0-3])(?::([0-5]?\\d))?(?::([0-5]?\\d))', 'gm')
const str = `00:00:00
00:00:01
23:59:17
01:01:01
10:17:25
09:56:17
22:56:59
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}