// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-1]?\d|2[0-3])(?::([0-5]?\d))?(?::([0-5]?\d))").unwrap();
let string = "00:00:00
00:00:01
23:59:17
01:01:01
10:17:25
09:56:17
22:56:59
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}