$re = '/([0-1]?\d|2[0-3])(?::([0-5]?\d))?(?::([0-5]?\d))/m';
$str = '00:00:00
00:00:01
23:59:17
01:01:01
10:17:25
09:56:17
22:56:59
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);