package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<airportCode>[A-Z0-9]{3})(?<providerCode>[A-Z0-9])(?<terminalCode>[A-Z0-9])(?<workstationCode>[A-Z0-9]{7})$`)
var str = `ABJE1CK00101`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}