$re = '/^(?<airportCode>[A-Z0-9]{3})(?<providerCode>[A-Z0-9])(?<terminalCode>[A-Z0-9])(?<workstationCode>[A-Z0-9]{7})$/m';
$str = 'ABJE1CK00101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);