re = /^(?<airportCode>[A-Z0-9]{3})(?<providerCode>[A-Z0-9])(?<terminalCode>[A-Z0-9])(?<workstationCode>[A-Z0-9]{7})$/m
str = 'ABJE1CK00101'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end