import re
regex = re.compile(r"^(?<airportCode>[A-Z0-9]{3})(?<providerCode>[A-Z0-9])(?<terminalCode>[A-Z0-9])(?<workstationCode>[A-Z0-9]{7})$", flags=re.MULTILINE)
test_str = "ABJE1CK00101"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")