using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\babc\d+_def(\d{2})\b";
string input = @"abc1_def23
abc10_def99
abc9_def9
eeabc1_def23
eeabc10_def99";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}