re = /\babc\d+_def(\d{2})\b/
str = 'abc1_def23
abc10_def99
abc9_def9
eeabc1_def23
eeabc10_def99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end