// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\babc\d+_def(\d{2})\b").unwrap();
let string = "abc1_def23
abc10_def99
abc9_def9
eeabc1_def23
eeabc10_def99";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}