package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\babc\d+_def(\d{2})\b`)
var str = `abc1_def23
abc10_def99
abc9_def9
eeabc1_def23
eeabc10_def99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}