#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^|/)\.(?!(specific_allowed_file|specific_allowed_folder)(/|$))"
Local $sString = "https://example.com/.forbidden_file" & @CRLF & _
"https://example.com/.forbidden_folder/somefile.txt" & @CRLF & _
"https://example.com/.specific_allowed_file" & @CRLF & _
"https://example.com/.specific_allowed_folder/somefile.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")