import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|/)\\.(?!(specific_allowed_file|specific_allowed_folder)(/|$))";
final String string = "https://example.com/.forbidden_file\n"
+ "https://example.com/.forbidden_folder/somefile.txt\n"
+ "https://example.com/.specific_allowed_file\n"
+ "https://example.com/.specific_allowed_folder/somefile.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}